youtube-dl: ValueError: insecure string pickle (OSX 10.11.6 homebrew)

Fehler:

$ youtube-dl https://www.youtube.com/watch?v=xX4321ZZYY
[youtube]xX4321ZZYY: Downloading webpage
[youtube]xX4321ZZYY: Downloading video info webpage
[youtube]xX4321ZZYY: Extracting video information
[youtube]xX4321ZZYY: Downloading MPD manifest
Traceback (most recent call last):
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/runpy.py", line 162, in _run_module_as_main
"__main__", fname, loader, pkg_name)
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/runpy.py", line 72, in _run_code
exec code in run_globals
File "/usr/local/bin/youtube-dl/__main__.py", line 19, in <module>
File "/usr/local/bin/youtube-dl/youtube_dl/__init__.py", line 465, in main
File "/usr/local/bin/youtube-dl/youtube_dl/__init__.py", line 455, in _real_main
File "/usr/local/bin/youtube-dl/youtube_dl/YoutubeDL.py", line 1919, in download
File "/usr/local/bin/youtube-dl/youtube_dl/YoutubeDL.py", line 773, in extract_info
File "/usr/local/bin/youtube-dl/youtube_dl/YoutubeDL.py", line 827, in process_ie_result
File "/usr/local/bin/youtube-dl/youtube_dl/YoutubeDL.py", line 1518, in process_video_result
File "/usr/local/bin/youtube-dl/youtube_dl/postprocessor/ffmpeg.py", line 60, in __init__
File "/usr/local/bin/youtube-dl/youtube_dl/postprocessor/ffmpeg.py", line 117, in _determine_executables
File "/usr/local/bin/youtube-dl/youtube_dl/postprocessor/ffmpeg.py", line 117, in <genexpr>
File "/usr/local/bin/youtube-dl/youtube_dl/utils.py", line 1907, in get_exe_version
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/subprocess.py", line 710, in __init__
errread, errwrite)
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/subprocess.py", line 1334, in _execute_child
child_exception = pickle.loads(data)
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/pickle.py", line 1382, in loads
return Unpickler(file).load()
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/pickle.py", line 858, in load
dispatch[key](self)
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/pickle.py", line 966, in load_string
raise ValueError, "insecure string pickle"
ValueError: insecure string pickle

Lösung:

$ brew install libav ffmpeg rtmpdump

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.